This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Second tinypilot as client
#1
Hi
I have not been able to connect my WiFi remote after new image.
Just tried the new (December). Following the instructions in the wiki I can do all steps until reboot. After changing host to 192.168.14.1 with nano and save I can go back and read the signalk.conf and it is the correct host 192.168.......
But after doing Sync and then reboot the file signalk.conf revert back to localhost as host.
how can I make The changes to stay after reboot???

Johan
  Reply
#2
It is possible another pypilot client process is running which already started with the localhost connection. If this connections succeeds on reconnect it would overwrite this file. I need to prevent this writing on a reconnect it seems.

For now either issue:
sv d pyilot
before using nano, or try editing the file on the sdcard from a reader on a different machine.
  Reply
#3
(01-14-2020, 07:25 PM)seandepagnier Wrote: It is possible another pypilot client process is running which already started with the localhost connection.   If this connections succeeds on reconnect it would overwrite this file.   I need to prevent this writing on a reconnect it seems.

For now either issue:
sv d pyilot
before using nano, or try editing the file on the sdcard from a reader on a different machine.

Thanks! it kind of works so now I know it possibleSmile 
using sudo sv d pypilot befor nano works when saving the conf file the remote directly connects to the main tinypilot. But after reboot file is back to localhost......

editing on a reader attached to a raspberry 4. if I use sudo nano to change the file I can save the file, but putting it back in the remote and turn it on the file is changed to localhost! 

something must be changing the signalk.conf at booting

Johan
  Reply
#4
I have written an interface to enable remote control from the lcd keypad menu for the next version.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)