This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hardware Acceleration for OpenCPN?
#11
What should it be set to? I want to try again.

And yes, it’s running on a Raspberry Pi 3 B (I think non-plus)
  Reply
#12
Maybe i missing something, but i found that OpenCPN hardware acceleration on rp 3b+ works for me only with

dtoverlay=vc4-kms-v3d

enabled in /boot/config.txt and "G1 GL" driver chosen in raspi-config (Advanced option->GL Driver)

OpenCPN works significantly faster but there one huge disadvantage for me: overscan/underscan options not working with vc4-kms-v3d driver, so i have black borders on one monitor or desktop not fit to screen on another...

one can test opengl with glxgears command. With fully enabled opengl it have to show about 60fps
  Reply
#13
I definitely also had the overscan issue that I wasn’t able to fix as usual!
On top of that, I could only select one resolution where without opengl I can select whatever I desire.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)