This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
no attribute 'MPU925xAccelFsr'
#1
I have a clean install on a pi 4, MPU9250 plugged in, and I am getting this message. Don't know where to start really. Does anayone have an idea?

Thx,

Code:
pi@pi4:~/pypilot $ history

 sudo apt install ujson pyudev
 sudo apt install python-pil
 sudo apt install python-flask python-gevent-websocket
 sudo apt install python-wxgtk3.0 python-opengl
 pip install  pyglet pywavefront

 git clone https://github.com/pypilot/pypilot
 git clone --depth 1 https://github.com/pypilot/pypilot_data
 cp -rv pypilot_data/* pypilot
 cd pypilot
 python setup.py build
 sudo python setup.py install

pi@pi4:~/pypilot $ pypilot_boatimu
ERROR loading learning.py No module named tensorflow ,  No module named learning
ERROR loading learning.py No module named tensorflow ,  No module named learning
Process Process-3:
Traceback (most recent call last):
 File "/usr/lib/python2.7/multiprocessing/process.py", line 267, in _bootstrap
   self.run()
 File "/usr/lib/python2.7/multiprocessing/process.py", line 114, in run
   self._target(*self._args, **self._kwargs)
 File "/usr/local/lib/python2.7/dist-packages/pypilot-0.11-py2.7-linux-armv7l.egg/pypilot/boatimu.py", line 52, in imu_process
   s.MPU925xAccelFsr = 0 # +- 2g
AttributeError: 'RTIMU.Settings' object has no attribute 'MPU925xAccelFsr'
got signal 17 cleaning up
  Reply
#2
You need to install RTIMULib modified by Sean, try this one: https://github.com/openplotter/python-RTIMULib2
It seems that this dependencie is missing on pypilot README. Sean?
  Reply
#3
Sad 
Thx. Installed it, then got a 'No IMU detected'. Soon thereafter I realised I had to enable i2c and spi in raspi-config Confused . Now it works.

So whether your link made it work - I cannot tell. How can I uninstall that package? I think I'm obliged to check that out now, am I not?

Cheers,

-
  Reply
#4
You have to keep RTIMULib installed to run pypilot. You can delete the installation folder after compiling.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)