This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power mode
#1
Hi to all.

I love this wonderfull project, thanks to all, especaly to Sean.

My Request would be if it is possible to add an simple Power Mode (in the Compass/GPS/Wind Window) stearing option.
This mode should simply  turn the drive fowerd/reverse by pressing the <> (Buttons) 1ximpulse (example 0.7 second) and <<>> (buttons) like 3ximpulse (example 2.1 second).

This would allow to test the stearing, to shorten or enlarge the ram of a tillerpilot for easy attach to the tiller and to test rudder angles or limit switches.

Thanks a lot
Andreas
  Reply
#2
It does this manual control mode when the autopilot is not engaged.

Do you want to manually override and drive the motor when the autopilot is engaged?
  Reply
#3
(03-21-2019, 09:44 PM)seandepagnier Wrote: It does this manual control mode when the autopilot is not engaged.

Do you want to manually override and drive the motor when the autopilot is engaged?

I did't expect the autopilot to do anything when not engaged/standby ...

It is working manual like you said....... it engages the clutch and stears right/left ....



I´m still fighting with with my old NECO 24V drive. Manualy it works, but the IMU/compass values 
start moving/fading (irrational) when the drive runs (5 meters distance). I guess this could be due to electromagnetic noise by the drive/brushes. I will first will try to change the connection btw. Pi and Nano to USB (right now it is 
5V/GND/TX/TX-Pins) and if this does not help y will start cheching the drive for flyback diodes  and capacitors to reduce noise. 

For now I use a simple H-Bridge consisting of two of the cheap chinese relays and a other relay for the cluch.


Are there any other suggestions ?
Is it possible to use an other compass source , NMEA or my old Simrad/Robertson RF35 ?

I´m having good fun with this project and learnig a lot.
Thank you verry much.

Save sailing to all and greetings from Spain
Andreas
  Reply
#4
(03-22-2019, 10:05 AM)xfactor99 Wrote:
(03-21-2019, 09:44 PM)seandepagnier Wrote: It does this manual control mode when the autopilot is not engaged.

Do you want to manually override and drive the motor when the autopilot is engaged?

I did't expect the autopilot to do anything when not engaged/standby ...

It is working manual like you said....... it engages the clutch and stears right/left ....



I´m still fighting with with my old NECO 24V drive. Manualy it works, but the IMU/compass values 
start moving/fading (irrational) when the drive runs (5 meters distance). I guess this could be due to electromagnetic noise by the drive/brushes. I will first will try to change the connection btw. Pi and Nano to USB (right now it is 
It sounds like magnetic interference. It doesn't matter if the drive is 5 meters away, do any of the high power wires come near the compass sensors? You might need to keep the motor controller farther from the pi.

Quote:5V/GND/TX/TX-Pins) and if this does not help y will start cheching the drive for flyback diodes  and capacitors to reduce noise. 

For now I use a simple H-Bridge consisting of two of the cheap chinese relays and a other relay for the cluch.
Relays really? I am using mosfets. This allows for variable speed control.
Quote:Are there any other suggestions ?
Is it possible to use an other compass source , NMEA or my old Simrad/Robertson RF35 ?
It is not supported. Maybe you could add this to the code, but the delay from the compass would give worse performance. Without a gyro rate the autopilot won't work very well.

It's best to find out why your compass readings change when the motor is running.
  Reply
#5
Hi Sean,

today I made the first sea trial and reported the setup an an other post.

I have one observation/question to make:

When in "Compass Mode" and active: I press the arrows > or >> to change course the course increases and the boat
changes to starboard. ---- That is as it should be.

When in "Power Mode" I press arrows > or >> to drive helm the boat changes to port !!!! that is somehow oposite
then before and verry confusing.

I had to switch the direcction cables, so the Autopilot works with compass, as I set it up in the harbour with the arrows in power mode and in compass mode it works the other way ...

Can I change this, so the behavior when changing by pressing the arrows to one side goes to the same direction indipendet if I
'm in power mode or compass mode ?

I hope I explained well.
Thanks
Andreas
  Reply
#6
I am not sure which version of pypilot you have but I know I did reverse it to fix this problem already once before. Is it still a problem from the latest git version? You must also rebuild the opencpn plugin from git if you upgrade.
  Reply
#7
(04-07-2019, 08:15 PM)seandepagnier Wrote: I am not sure which version of pypilot you have but I know I did reverse it to fix this problem already once before.   Is it still a problem from the latest git version?  You must also rebuild the opencpn plugin from git if you upgrade.

I'm using Pypilot wich is in the actual Openplotter. As I don't know how to update the latest "GIT" I might wait for a new Openplotter ...... or is it just copying the Autopilot.py file from Github. I´m that I will "corrupt" my running system by changing single files.
Thanks
Andreas
  Reply
#8
(04-08-2019, 01:14 PM)xfactor99 Wrote:
(04-07-2019, 08:15 PM)seandepagnier Wrote: I am not sure which version of pypilot you have but I know I did reverse it to fix this problem already once before.   Is it still a problem from the latest git version?  You must also rebuild the opencpn plugin from git if you upgrade.

I'm using Pypilot wich is in the actual Openplotter. As I don't know how to update the latest "GIT" I might wait for a new Openplotter ...... or is it just copying the Autopilot.py file from Github. I´m that I will "corrupt" my running system by changing single files.
Thanks
Andreas

Sorry .... I should read better .... just found at pypilot.org >>> wiki >>>> upgrading from git !!!!
Will give it a try later this week (after making a backup) and saving pypilot.conf

Thanks
Andreas
  Reply
#9
Hi Sean.

I updated Pypilot for Openplotter as stated in your WIKI. 
It worked fine. and now the movement of the helm  iniciated out of the Pypilot Control is correct.
Will say course to the right in compassmode and press tou the right in powermode all turns to Starboard.

The problem Is updating the OpenCPN Plugin wich still goese in powermode to port.

First I tired updating out of the Update-Option for plugins of Pypilot and also out of the terminal.
It sates that I have the latest update.


Then I tried to compile: with your instructions for the RPI:

"""""""
Compiling
=========

* git clone git://github.com/seandepagnier/pypilot_pi.git

Do NOT attempt to build this plugin from within the OpenCPN source tree.

Under windows, you must find the file "opencpn.lib" (Visual Studio) or "libopencpn.dll.a" (mingw) which is built in the build directory after compiling opencpn.  This file must be copied to the plugin directory.

Build as normally:

* cd ..
* cd build
* cmake ..
* make
* make install

""""""

first the /gitub.com/seandepagnier/ must be github.com/pypilot I guess

after I downloaded. (wich works)

I was unable to compile with the above instructions an al trying arround and searching did not work


dont find folder "cd buid" sometimes wxWidgets-problem

I also spend a night trying to compile for windows with visual studio and I had no success.
So many options so many problems ....

It is far above my knowllege to do this ..... (And I guess also above many others)

I give up .......


Would it be possible that you or someone of the projeot OpenPlotter can provide
something more simple to update the Pypilot OpenCPN-Plugin (for the RPI and for Windows)
maybe an already compiled file witch we can download somewere and just copy to an specified location ???

or at least some instructions (that work)

Please help

Andreas
  Reply
#10
http://pypilot.org/wiki/doku.php?id=upgrading_from_git
i dont know about the opencpn plugin
mare liberum
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)